FANDOM


Getting Started
System Requirements  · Download  · Port  · Controls  · Game Modes  · In-Game Currency

General information

As of update 0.7.3, these are the minimum requirements for running WoWSB

  • Operating System: iOS 9 or later
  • Internet Connection Speed: 256 Kbps (Wi-Fi preferably)
  • Minimum Recommended Devices: iPad 4 and up / iPhone 5 and up / iPod touch 5th generation
  • Supported Devices:
    • iPad Air 2 and up
    • iPhone 6S and up
    • iPod touch 6th Gen

Notice

"Jailbroken" devices are not officially supported.

  • Operating System: Android 5.0 or later
  • Processor: Dual Core 1.2 GHz (minimum) or better
  • GPU: At least, Mali-400MP, Adreno 320, PoweVR SGX544 or Nvidia Tegra 3
  • RAM:  2 GB RAM and above
  • Storage:: +5GB. The download and install size is device dependent.
  • Internet: Broadband Internet Connection

Notice

Please be aware, that even if the device meets the minimum requirements, it may still be unable to run the game. Verify device compatibility by checking the Play Store.

Android devices with a third-party firmware or Root-rights are not officially supported.

External Links

  1. https://wowsblitz.com/en/system-requirements/
  2. https://wgmobile.zendesk.com/hc/en-us/articles/115003973793-What-are-the-system-requirements-for-World-of-Warships-Blitz-
Community content is available under CC-BY-SA unless otherwise noted.